Alessandro Del Sole's Blog

{ A programming space about Microsoft® .NET® }
posts - 1909, comments - 2047, trackbacks - 352

My Links

News

Your host

This is me! Questo spazio è dedicato a Microsoft® .NET®, di cui sono molto appassionato :-)

Cookie e Privacy

Microsoft MVP

My MVP Profile

Microsoft Certified Professional

Microsoft Specialist

Xamarin Certified Mobile Developer

Il mio libro su VB 2015!

Pre-ordina il mio libro su VB 2015 Pre-ordina il mio libro "Visual Basic 2015 Unleashed". Clicca sulla copertina per informazioni!

Il mio libro su WPF 4.5.1!

Clicca sulla copertina per informazioni! E' uscito il mio libro "Programmare con WPF 4.5.1". Clicca sulla copertina per informazioni!

These postings are provided 'AS IS' for entertainment purposes only with absolutely no warranty expressed or implied and confer no rights.
If you're not an Italian user, please visit my English blog

Le vostre visite

I'm a VB!

Guarda la mia intervista a Seattle

Follow me on Twitter!

Altri spazi

GitHub
I miei progetti open-source su GitHub

Article Categories

Archives

Post Categories

Image Galleries

Privacy Policy

Internet Explorer 8: problema e soluzione per ASP.NET

Dopo aver installato Internet Explorer 8, mi si era presentato un problema: ogni qual volta mandavo in esecuzione da Visual Studio 2008 un progetto Silverlight, invece di visualizzare l'applicazione veniva mostrato un triste messaggio: "Internet Explorer cannot display the webpage". Questo si verificava sia con progetti nuovi che esistenti (quindi già testati e funzionanti).

Dopo suggerimenti di test vari, è balzato all'occhio che il problema riguardava tutte le applicazioni ASP.NET e che probabilmente si trattava di un problema di security sollevato sui server Web locali.

Al termine delle numerose ricerche su Internet ho trovato una soluzione, ossia modificare il file chiamato Hosts che risiede nella cartella C:\Windows\System32\Drivers\etc. In particolare, nella riga contenente la dicitura "::1  localhost", è bastato sostituire "::1" con ":::1" aggiungendo un ":" in più.

E ora funziona. Se vi dovesse capitare, provate così :-)

Alessandro

Print | posted on domenica 19 aprile 2009 03:39 | Filed Under [ .NET Framework Visual Studio 2008 Silverlight e Windows Phone WCF Data Services/WCF RIA Services/OData ]

Powered by:
Powered By Subtext Powered By ASP.NET