Alessandro Del Sole's Blog

{ A programming space about Microsoft® .NET® }
posts - 1909, comments - 2047, trackbacks - 352

My Links

News

Your host

This is me! Questo spazio è dedicato a Microsoft® .NET®, di cui sono molto appassionato :-)

Cookie e Privacy

Microsoft MVP

My MVP Profile

Microsoft Certified Professional

Microsoft Specialist

Xamarin Certified Mobile Developer

Il mio libro su VB 2015!

Pre-ordina il mio libro su VB 2015 Pre-ordina il mio libro "Visual Basic 2015 Unleashed". Clicca sulla copertina per informazioni!

Il mio libro su WPF 4.5.1!

Clicca sulla copertina per informazioni! E' uscito il mio libro "Programmare con WPF 4.5.1". Clicca sulla copertina per informazioni!

These postings are provided 'AS IS' for entertainment purposes only with absolutely no warranty expressed or implied and confer no rights.
If you're not an Italian user, please visit my English blog

Le vostre visite

I'm a VB!

Guarda la mia intervista a Seattle

Follow me on Twitter!

Altri spazi

GitHub
I miei progetti open-source su GitHub

Article Categories

Archives

Post Categories

Image Galleries

Privacy Policy

Add-in per Visual Studio 2005, problemi nel riconoscimento.

Ieri sera Diego Cattaruzza ed io stavamo facendo un test su degli add-in per Visual Studio 2005. Nonostante gli add-in fossero scritti e compilati correttamente, all'avvio di Visual Studio 2005 veniva visualizzato un messaggio di errore che comunicava l'impossibilità di caricare il componente aggiuntivo (errore 80004005).

Come probabilmente sapete, gli add-in per Visual Studio 2005 sono costituiti da due file: il primo, l'assembly .dll che costituisce il componente aggiuntivo vero e proprio, e il secondo, un file .addin, a struttura XML, che descrive il componente aggiuntivo e fornisce all'IDE le informazioni necessarie per il suo riconoscimento. Diego ha avuto la brillante intuizione di andare a curiosare nel file .addin, scoprendo che Visual Studio 2005 aveva inserito una doppia estensione .dll al nome del componente aggiuntivo (elemento <Assembly>). Rimossa questa doppia estensione (è sufficiente il Blocco Note di Windows), il tutto ha funzionato correttamente. Ho voluto provare anch'io, con un'altra mia add-in. Effettivamente si è ripresentato lo stesso problema, risolto con la modalità di cui sopra.

Al momento stiamo indagando sulle cause, se qualcuno ne sa già qualcosina in più... lo attendiamo con piacere! :D

Alessandro

Print | posted on domenica 15 luglio 2007 14:28 | Filed Under [ Visual Studio Extensibility ]

Powered by:
Powered By Subtext Powered By ASP.NET